Ошибки в us0.37.5

Bugs (reports, fixes, etc.)

Postby moroz1999 » 22 Apr 2011, 20:41

Сначала б только проблему с fast=0 пофиксить, а то порт с явными багами - не айс.
User avatar
moroz1999
 
Posts: 368
Joined: 02 Aug 2009, 12:26
Group: Registered users

Postby moroz1999 » 24 Apr 2011, 14:32

Чтобы проиллюстрировать серьезность проблемы, добавлю:
С fast=0 не сработала Silence Of The AY:
http://zxaaa.untergrund.net/demo.php?s= ... itle=Title
Демо стартует, но дигитальная музыка не грузится.

По моему опыту это сейчас - единственная заметная проблема в эмуляции на данный момент.
User avatar
moroz1999
 
Posts: 368
Joined: 02 Aug 2009, 12:26
Group: Registered users

Postby deathsoft » 24 Apr 2011, 16:11

moroz1999 wrote:Демо стартует, но дигитальная музыка не грузится.

Но она и в эмуляторе zxmak не играет, там поди диск у ААА неверно скопирован. В эмуляторе realspectrum тоже дигитала нету.
User avatar
deathsoft
 
Posts: 4635
Joined: 07 Apr 2007, 00:58
Group: Registered users

Postby moroz1999 » 24 Apr 2011, 16:54

Прошу прощения, реально ложная тревога.
Авторы решили из интерфейса ребусов понаделать, там по два раза подряд надо мелодию выбирать, чтобы что-то услышать.
User avatar
moroz1999
 
Posts: 368
Joined: 02 Aug 2009, 12:26
Group: Registered users

Postby нолька » 24 Apr 2011, 17:29

тока что проверил - играет :)
<alone> предлагаю тслабсу дать транк, но с условием чтобы он впилил туда спрайтотайлы, но не трогал атм
<LordVader> alone: яготов всосать срайты от тслабса )
<LordVader> атм режимы это пиздец
User avatar
нолька
рОвный
 
Posts: 1200
Joined: 08 Apr 2007, 20:12
Group: Registered users

Postby deathsoft » 24 Apr 2011, 18:34

Ну, да, если по 2 раза жать - то играет.
User avatar
deathsoft
 
Posts: 4635
Joined: 07 Apr 2007, 00:58
Group: Registered users

Postby DimkaM » 08 Jul 2011, 16:18

del
N>"Идите нахуй" со своей политикой...
DimkaM
 
Posts: 1003
Joined: 24 Mar 2010, 12:42
Location: г.Щёлково М.О.
Group: Registered users

Postby Петр » 11 Sep 2011, 22:28

На образе TR-DOS дискеты возможно 129 файлов.
Такое возникает при подключении образа, на котором уже есть 128 файлов. Файл boot.B приписывается 129-м.
Image
Файл выводится по LIST и CAT, но не запускается по RUN и RUN "boot". Пишет "No File(s)".
Вывод листинга файлов скорпионовским сервис-монитором, после вывода 128 файлов, подвисает и нужно производить reset.
Информация о файле записывается в образ в трек=0, сектор=8.
Image

Пожалуйста, сделайте в следующей версии, чтобы, если на дискете уже 128 файлов, то файл boot.B не приписывается.
Петр
 
Posts: 13
Joined: 04 May 2011, 21:49
Group: Registered users

Postby Петр » 11 Sep 2011, 22:47

Добавка к предыдущему сообщению.
Если сохранить образ, а потом заново подключить, то получится уже 130 файлов.
Image
Петр
 
Posts: 13
Joined: 04 May 2011, 21:49
Group: Registered users

Postby deathsoft » 12 Sep 2011, 17:48

Надо будет пофиксить этот баг. Видимо не контролируется выход за граниы каталога.
User avatar
deathsoft
 
Posts: 4635
Joined: 07 Apr 2007, 00:58
Group: Registered users

PreviousNext

Return to Ошибки

Who is online

Users browsing this forum: No registered users and 1 guest